Configuring route summary addresses for EIGRP.
Route summaries reduce the size of the routing table,
improves convergence and cpu load along with memory usage. We will use
the diagram below for our configurations. The data center router has many
subnets and we need to aggregate those routes onto the core routers. In order
to have a sustainable route summary plan, you need to carefully plan out your
ip addressing scheme/subnet assignments.
In order for an EIGRP route summary
to be advertised to the neighboring device, you must have at least one
interface using one of the subnets in the aggregate and the interface must be
up/up. In our case we will use loopback interfaces to simulate this. You can
configure multiple aggregate addresses under the interface as we are doing.
Unlike OSPF you can summarize on any router, in OSPF you can only perform
summarization an ABR or ASBR.
LoopBacks were created before hand and
ip's have were assigned. These interfaces need to be associated with the EIGRP process using the network command.
Dist_Data_Center_NJ#show ip int
brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Loopback10 206.200.0.1 YES manual up up
Loopback11 206.200.5.1 YES manual up up
Dist_Data_Center_NJ#
Associating the new loopback interfaces and future loopbacks.
Dist_Data_Center_NJ(config)#router eigrp 10
Dist_Data_Center_NJ(config-router)# network 206.200.0.0 0.0.3.255
Dist_Data_Center_NJ(config-router)# network 206.200.4.0 0.0.3.255
Confirms which interfaces are park of the EIGRP process.
Dist_Data_Center_NJ#show ip eigrp interfaces
IP-EIGRP interfaces for process 10
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 1 0/0 28 0/2 116 0
Lo11 0 0/0 0 0/1 0 0
Lo10 0 0/0 0 0/1 0 0
Dist_Data_Center_NJ#
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Loopback10 206.200.0.1 YES manual up up
Loopback11 206.200.5.1 YES manual up up
Dist_Data_Center_NJ#
Associating the new loopback interfaces and future loopbacks.
Dist_Data_Center_NJ(config)#router eigrp 10
Dist_Data_Center_NJ(config-router)# network 206.200.0.0 0.0.3.255
Dist_Data_Center_NJ(config-router)# network 206.200.4.0 0.0.3.255
Confirms which interfaces are park of the EIGRP process.
Dist_Data_Center_NJ#show ip eigrp interfaces
IP-EIGRP interfaces for process 10
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 1 0/0 28 0/2 116 0
Lo11 0 0/0 0 0/1 0 0
Lo10 0 0/0 0 0/1 0 0
Dist_Data_Center_NJ#
I updated the interface with the
summary command, highlighted in red. This will cause your neighborship to
re-sync.
Dist_Data_Center_NJ#show run int
f0/0
Building configuration...
Current configuration : 212 bytes
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.252
ip summary-address eigrp 10 206.200.4.0 255.255.252.0 5
ip summary-address eigrp 10 206.200.0.0 255.255.252.0 5
duplex auto
speed auto
end
Building configuration...
Current configuration : 212 bytes
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.252
ip summary-address eigrp 10 206.200.4.0 255.255.252.0 5
ip summary-address eigrp 10 206.200.0.0 255.255.252.0 5
duplex auto
speed auto
end
CORE_NJ_WAN_1#
*Mar 1 00:09:06.307: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.5.1 (FastEthernet0/0) is resync: peer graceful-restart
*Mar 1 00:09:06.307: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.5.1 (FastEthernet0/0) is resync: peer graceful-restart
CORE_NJ_WAN_1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.5.0/30 is subnetted, 1 subnets
C 192.168.5.0 is directly connected, FastEthernet0/0
D 206.200.0.0/22 [90/409600] via 192.168.5.1, 00:18:06, FastEthernet0/0
D 206.200.4.0/22 [90/409600] via 192.168.5.1, 00:16:26, FastEthernet0/0
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.5.0/30 is subnetted, 1 subnets
C 192.168.5.0 is directly connected, FastEthernet0/0
D 206.200.0.0/22 [90/409600] via 192.168.5.1, 00:18:06, FastEthernet0/0
D 206.200.4.0/22 [90/409600] via 192.168.5.1, 00:16:26, FastEthernet0/0
No comments:
Post a Comment