Thursday, February 23, 2012

EIGRP PART3

EIGRP K VALUES/Metrics:

By default EIGRP only uses 

K1= Bandwidth (Default) least bandwidth of all outgoing interfaces on the route to the destination network.
K2= Load

K3= Delay(Default) the sum of the delays configured on the interfaces, on the route to the destination network, in tens of microseconds.
K4= Reliabitly
K5=  MTU

Verify K values in use:

R1#show ip protocols
Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 10
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.1/32
  Passive Interface(s):
    FastEthernet0/1
    VoIP-Null0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

R1#




 EIGRP NEIGHBORSHIP FORMATION:

You can define static neighbor ships or dynamic ones. Under the router eigrp process you will need to define the static neighbor.

router eigrp 10
neighbor 192.168.1.2 fastEthernet 0/0


Verify static neighbor: Note the difference how shows you the static neighbor and the other does not.


R1#show ip eigrp neighbors detail
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             14 00:00:10   46   276  0  13
   Static neighbor
   Version 12.4/1.2, Retrans: 0, Retries: 0

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             14 00:00:19   46   276  0  13
R1#



The caveat with this is that you can not form dynamic neighborships once you specify a static neighbor via that interface. EIGRP disables all multicast messaging via that interface. You also still need to specify the network command for that specific interface.


 

Monday, February 20, 2012

EIGRP Part 2 (Authentication - Keychain)

Enable Authentication under the EIGRP interface:

R2(config-if)#ip authentication mode eigrp 10 md5
R2(config-if)#ip authentication key-chain eigrp 10 joel

Configure keychain # and Password:

R2(config)#key chain joel
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string joel
R2(config-keychain-key)#default send-lifetime
R2(config-keychain-key)#default accept-lifetime

Verify that EIGRP authentication is being used.

R2#show ip eigrp interfaces detail fastEthernet 0/0
IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              1        0/0        54       0/2           50           0
  Hello interval is 5 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/4  Un/reliable ucasts: 8/23
  Mcast exceptions: 3  CR packets: 3  ACKs suppressed: 0
  Retransmissions sent: 15  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "joel"  Use multicast
R2#
R2#show key chainKey-chain joel:
    key 1 -- text "joel"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]
R2#

EIGRP 1 Part 1

EIGRP; Enhance Interior Gateway Protocol is a Cisco Propriety protocol and can only be used between Cisco devices which is a downfall as it is one of the fastest protocols when it comes to convergence due to the way it works. EIGRP has something called successor route and feasible successor route. It pretty much remembers the alternative path in-case the (Primary) success route is removed from the routing table. Even though the (secondary) path by have a worse metric, it still keeps it in the topology table. EIGRP uses well known multicast address 224.0.0.10(IPV4) and ff02::a(IPV6) to communicate with its neighbors. EIGRP only advertises its full routing table when it first establishes a neighborship. The rest of the updates are triggered updates (when a network change occurs)


Router(config)#int f0/0
Router(config-if)#no shut
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config)#router eigrp 10
Router(config)#no auto-summary (disables auto summary for classes addresses)
Router(config-router)#passive-interface default  (Enable passive interface for all interfaces on this device for eigrp process 10)
Router(config-router)#no passive-interface fastEthernet 0/0  (Exclude interface f0/0 from being a passive interface, hellos can be sent now)
Router(config-router)#network 192.168.1.1 0.0.0.0 
Router(config-router)#exit

This is how your verify which interfaces are in passive mode.

Router#show ip protocols
Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 10
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.1/32
  Passive Interface(s):
    FastEthernet0/0
    FastEthernet0/1
    VoIP-Null0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

Verify Eigrp hello timer. The default is 5 seconds. 3 to 1 ratio on the hold time.

Router#show ip eigrp interfaces detail fastEthernet 0/0
IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              1        0/0        45       0/2           50           0
  Hello interval is 5 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/1  Un/reliable ucasts: 1/3
  Mcast exceptions: 1  CR packets: 1  ACKs suppressed: 0
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast
Router#

Verify EIGRP hold time. The default is 15seconds  There is no way if knowing what is configured unless your issue a show run which is not always allowed on the ccnp exams so you need to guesstimate but this should be fairly simple.

Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             11 00:02:14   45   270  0  3
Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             13 00:02:18   45   270  0  3
Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             12 00:02:19   45   270  0  3
Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             11 00:02:19   45   270  0  3
Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             10 00:02:20   45   270  0  3
Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             10 00:02:25   45   270  0  3
Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             13 00:02:27   45   270  0  3
Router#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/0             12 00:02:28   45   270  0  3
Router#

Updating Hello and Hold Timer. You can not do this on a per neighbor case, all neighbors known through this interface will have to abide by these settings. Think if your using a switch with one core vlan.

3 to 1 ratio recommended. This tells your neighbor device that he needs to send you a hello before 6 seconnds and this also tells your router to send a hello every 2 seconds.

Router(config-if)#ip hello-interval eigrp 10 2
Router(config-if)#ip hold-time eigrp 10 6 


Cisco Policing Configuration.

This is a common configuration found on many ISP routers that limit customer traffic. You can apply this inbound or outbound. You can apply it in both directions at once if you want.  I was able to successfully test it using testmy.net and wan killer from solar winds. 

Equipment Used: Cisco 2851.

(Specify interesting traffic that should be matched. In this case, all traffic)

ip access-list standard police-1mb-internet  
permit any
exit
!

(Classify which traffic this class map applies to)

class-map 1mb-police-internet-class-map
description police-internet outbound traffic to 1mb
match access-group name police-1mb-internet
exit
!

(What policy should be applied to traffic that is classified by the class map)

policy-map 1mb-police-internet-policy-map
description police-internet outbound traffic to 1mb
class 1mb-police-internet-class-map
police cir 1000000 exceed-action drop
exit
!
(Which direction do you want to apply this in and which interface.)

interface gi0/1
service-policy output police-1mb-internet
end
!
WR
!


Policer Applied
Policer Unapplied

Friday, February 17, 2012

Layer 2 Vlan Tagging for Servers. Virtual Machine


Today I had a request from a business user that needed to have two vlans that were on the same switch for one of his virtual machines. In order to accomplish this, we made the switchport a trunk port and allowed the vlans he only needed.  Also note that sometimes when a server is booting up it might send untagged frames so you need to specify the native vlan. If this host needs to pxe boot or get some dhcp details and those services live on a specific vlan, use that are your naitive Vlan.

interface GigabitEthernet3/7
specify which module (3) and interface(7) you want to configure
 description  us03wtc3456
(You can put anything you want in here. I have seen people put 1800 numbers and circuit id's)
 switchport 
(Sometimes required, depends on what capabilities your switch and or module has.
 switchport trunk encapsulation dot1q 
(specifies which tagging method your going to use. This is most common)
 switchport trunk native vlan 928
(Any untagged frames will be processed as Vlan 928)
 switchport trunk allowed vlan 928,944-946
 (Vlans allowed on this trunk)
 switchport mode trunk
(Make this a trunk port)
 logging event link-status
 (Any time this interface goes up/down/err-disable its logged)
 speed 1000
(Port speed - no need to explain)
 duplex full
(Duplex - no need to explain)

Layer 2 Multicast Arista

Layer2 Multicast Troubleshooting tips. Some stuff I learned today from the SR guys at work.

Show ip igmp snooping (Confirms which host are sending IGMP reports as you can trace back what’s connected to that specific port)

Show ip igmp snooping groups (Confirms which groups hosts are trying to subscribe to)

Show spanning-tree vlan X/X (Confirms which way the multicast data is flowing)

So how do confirm multicast data is actually being disseminated from a host on a layer 2 switch? You get the big guns out and put a sniffer up. That’s the fastest and easiest way to determine why host's that are sending out reports are not getting multicast data. You can also run into issues where a specific ASIC for a group of ports is not working properly (Not common but it does happen).

Eventually I would like to do reviews on all the tools at have at my possesion at work, to name a few Gigamon, Netscout, Apcon Matrix Switch, Network General Sniffer and Niksun. Arista switches and a Ton of nexus gear.

Tuesday, February 14, 2012

Nexus and IOS commands

Second Post: Two cool commands I learned today. The show interface capabilities command I ended up having to use it becasue I could not apply switchport trunk encapsulation dot1q to a interface. Once I issued show interfaces capabilities module X I was able to tell why. It only supported 802.1Q trunking so there was no need to specify it. I was googling some stuff about UDLD and I came across show errdisable detect so I figured I would share it.

6509#show interfaces capabilities module 9
GigabitEthernet9/1
  Model:                 WS-X6748-SFP
  Type:                  1000BaseSX
  Speed:                 1000
  Duplex:                full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on,desired),tx-(off,on,desired)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q8t), tx-(1p3q8t)
  QOS queueing mode:     rx-(cos), tx-(cos)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          no
  Inline power policing: no
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    yes
  Ports-in-ASIC (Sub-port ASIC) : 1,3,5,7,9,11,13,15,17,19,21,23,25,27,29,31,33,35,37,39,41,43,45,47 (1,3,5,7,9,11,13,15,17,19,21,23)
  Remote switch uplink:  no
  Dot1x:                 yes
  Port-Security:         yes

NX-OS# show interface capabilities
Ethernet1/1
  Model:                 N5K-C5020P-BF-SUP
  Type (SFP capable):    Fabric Extender Transceiver
  Speed:                 1000,10000
  Duplex:                full
  Trunk encap. type:     802.1Q
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off/on),tx-(off/on)
  Rate mode:             none
  QOS scheduling:        rx-(6q1t),tx-(1p6q0t)
  CoS rewrite:           no
  ToS rewrite:           no
  SPAN:                  yes
  UDLD:                  yes
  Link Debounce:         yes
  Link Debounce Time:    yes
  MDIX:                  no
  Pvlan Trunk capable:   yes
  TDR capable:           no
  Port mode:             Switched
  FEX Fabric:            yes
  POE capable:           no


6509#show errdisable detect
(NX-OS Does not have a similar CMD)
ErrDisable Reason    Detection status
-----------------    ----------------
udld                                    Enabled
bpduguard                               Enabled
security-violation                      Enabled
channel-misconfig                       Enabled
psecure-violation                       Enabled
mac-limit                               Enabled
unicast-flood                           Enabled
vmps                                    Enabled
loopback                                Enabled
pagp-flap                               Enabled
dtp-flap                                Enabled
link-flap                               Enabled
l2ptguard                               Enabled
gbic-invalid                            Enabled
dhcp-rate-limit                         Enabled
storm-control                           Enabled
inline-power                            Enabled
arp-inspection                          Enabled
packet-buffer                           Enabled
link-monitor-failure                    Enabled
oam-remote-failure critical-event       Enabled
oam-remote-failure dying-gasp           Enabled
oam-remote-failure link-fault           Enabled
dot1ad-incomp-etype                     Enabled
dot1ad-incomp-tunnel                    Enabled
mvrp                                    Enabled
CAREXTCR1A#